[BCAB] Your browser is not supported

Tiddy Ogg tiddyogg at madasafish.com
Fri Feb 28 19:02:30 GMT 2014


On 28/02/2014 17:34, Ruth Gillespie wrote:
> Hi all,
>
> I am getting this message and am being advised to install Google
> Chrome but I have installed it and find it very hard to navigate. I'm
> using IE9 so would appreciate advice on this.
>
> Many Thanks
>
> Ruth
>
You could try Firefox.






More information about the Bcab mailing list