[BCAB] Extremely frustrated! error 500 when using WD sync on nas can anyone help?

John Sexton bcab at developer.plus.com
Thu Aug 4 13:24:19 BST 2016

Hi Mo,

I found this article on how to setup your x2ultra cloud sync:

It may be worth searching the WD knowledge base or the WD community pages,
to see if anyone else with this device has had a similar experience.

All the best,

John Sexton  -  Freelance web developer & accessibility specialist
www.abc4accessibility.com        |         john at developer.plus.com
Tel:  01255 428138               |              Mob:  07540 851309
Skype: john_20762                |           Twitter: @JohnenRebel

-----Original Message-----
From: Bcab [mailto:bcab-bounces at lists.bcab.org.uk] On Behalf Of Mobeen Iqbal
Sent: 04 August 2016 12:00
To: Blind sysadmins list; BCAB Discussion List
Subject: [BCAB] Extremely frustrated! error 500 when using WD sync on nas
can anyone help?

Hello Everyone.

I have just purchased a western digital nas, model EX2Ultra. I'm liking 
it in terms of accessibility so far but can't for the life of me get 
cloud sync to work to sync folders over my local lan which is my primary 
reason for the purchase. I've enabled cloud access on the device and 
made sure my user has cloud access enabled. I have not signed up for a 
my cloud account because every time I click sign up and enter my email 
and click save, I don't receive any emails from western digital. Do I 
need to sign up for an online account to use cloud storage? surely I 
shouldn't need to sign up to use it via a lan? When I install WD sync, 
the device is detected. I'm prompted to log in and the log in 
information is accepted. I then get the option to sync folders and by 
default, my user profile folders are checked. I click continue and at 
that point, I get the following error.

wd sync The remote server returned an error: (500) Internal Server Error.

Which doesn't tell me anything. Here's what I've done so far.

* soft and hard restarted the device multiple times.
* reset the device to factory defaults using a full reset.
* Tried to contact western digital. I've received 2 confirmation emails 
which tell me to send them system logs and that the case is open, but no 
reply from them so far.
* Tried adding other user accounts, same error.
* Tried installing on another machine on the same lan, same error.

Does anyone have any idea what's going on and why the server would be 
throwing an error 500? It doesn't really tell anyone anything. The 
dashboard is working fine.

all the best,


To find out more about BCAB and the benefits that membership can bring,
please visit our website: https://www.bcab.org.uk/
Manage your subscription by logging in with your BCAB account details at :
Access the publicly searchable list archives at:
To discuss matters relating to the mailing list, please email:
moderator at bcab.org.uk.

More information about the Bcab mailing list